7.19.1
πŸ₯
Local Code Systems
πŸ‘©β€βš•οΈπŸ‘¨β€βš•οΈ Collaborative authoring
πŸ›‘
Error Handling
Views
Views support editors and provide alternative presentations as well as ways to navigate through information. For example, the SNOMED CT View displays the structure of the SNOMED CT terminology as a tree of concepts.
The following views are available in Snow Owl:
View
Description
SNOMED CT View
Displays concepts in a tree structure that reflects their hierarchy
​
ICD-10 View
Displays ICD-10, (ICD-10-UK, ICD-10-AM, ICD-10-CM) codes in a tree structure
​
Parents View
Displays the parents of a selected concept. Parents are displayed at the bottom of the tree structure (which is inverse to the way they are displayed in the concept views above)
​
Project Explorer View
Contains files used for querying, script projects, and other resources
​
History View
Displays the history of a SNOMED CT concept
​
Search View
Displays search results
​
Validation Issues View
Displays errors, warnings, and information messages about the concepts
​
Bookmarks View
Allows you to bookmark concepts to make it easier to find them again (just like the bookmarks in your Internet browser)
​
Commit Information View
Displays the latest changes to the terminology, including the person that made the change and their comment about the change
​
Error Log View
Displays error log file that is useful for troubleshooting
​
Reference Set View
Displays Reference Sets grouped by their type
​
Value Sets View
Displays Value Sets
​
Mapping Sets View
Displays Mapping Sets
Views for other terminologies
​
OPCS-4,
LOINC,
ATC,
NICIP,
Local Code System codes in a tree structure
The SNOMED CT, ICD-10, OPCS-4, ATC, LOINC, Value Set, Mapping Set Views are sometimes referred to as concept navigators since they allow navigating through the hierarchy.
To take a look at all available views, select Window > Show View. To bring up a view that isn't displayed on the user interface, go to Window > Show View > Other > Snow Owl.
Views that are already open are greyed out on the list.
Available Views
Views have their own menus and toolbars; the actions represented by buttons on the toolbar only affect the items within that view.
Stacked Views
You can resize and arrange views by dragging them to different docking positions in the user interface.
When dragging a view, you can see how the perspective would change indicated with grey lines/rectangles.
If you drop the view when rectangles are displayed, the view will be docked as a separate window; if a single line appears next to a view tab, it will be docked as a tabbed notebook.
Views can not be docked in the central area because it is reserved for editors.
Export as PDF
Copy link